Otter Services Down
Resolved·Full outage

Otter systems have been fully restored.

Thu, Nov 13, 2025, 07:36 PM
(2 months ago)
·
Affected components
Otter Website
Updates

Resolved

Otter systems have been fully restored.

Thu, Nov 13, 2025, 07:36 PM

Monitoring

Our engineering team has identified the issue.

We have resumed operations but will continue to monitor the situation.

Thu, Nov 13, 2025, 04:15 PM(3 hours earlier)

Investigating

We are currently experiencing an outage with Otter services.

Our team is aware and working on a solution as soon as possible.

Thu, Nov 13, 2025, 04:09 PM