Resolved
Otter systems have been fully restored.
Monitoring
Our engineering team has identified the issue and applied a fix
We have resumed operations but will continue to monitor the situation.
Investigating
We are currently experiencing an outage with Otter services.
Our team is aware and working on a solution as soon as possible.