Otter Website May be Unreachable
Resolved·Degraded performance

Otter systems have been fully restored.

Tue, Sep 2, 2025, 11:26 PM
(10 minutes ago)
·
Affected components
Otter Website
Updates

Resolved

Otter systems have been fully restored.

Tue, Sep 2, 2025, 11:26 PM

Monitoring

Our engineering team has identified the issue.

We have resumed operations but will continue to monitor the situation.

Tue, Sep 2, 2025, 08:02 PM(3 hours earlier)

Investigating

Otter Services have experienced a brief outage, and may be intermittently unreachable.

Our team is aware and working to identify the root cause as soon as possible.

Tue, Sep 2, 2025, 04:19 PM(3 hours earlier)