Slow syncing of calendar events
Resolved·Degraded performance

Otter systems have been fully restored.

Fri, Jun 6, 2025, 05:43 PM
(3 months ago)
·
Affected components
Updates

Resolved

Otter systems have been fully restored.

Fri, Jun 6, 2025, 05:43 PM

Investigating

Some users may be experiencing slow syncing of their Google or Microsoft calendars.

Our team is investigating the issue and will publish updates as we diagnose and address it.

Wed, Jun 4, 2025, 05:29 PM(2 days earlier)