Maintenance - Microsoft Sign-in temporarily unavailable
Resolved·Degraded performance

Maintenance is complete. Microsoft sign-in is available.

If you are experiencing any issues with Microsoft sign-in, please sign in to Otter and submit a request through Contact Support in the profile settings.

Fri, May 30, 2025, 12:20 AM
(1 month ago)
·
Affected components
Updates

Resolved

Maintenance is complete. Microsoft sign-in is available.

If you are experiencing any issues with Microsoft sign-in, please sign in to Otter and submit a request through Contact Support in the profile settings.

Fri, May 30, 2025, 12:20 AM

Monitoring

Maintenance is occurring for Microsoft sign-in. Signing in to Otter and/or connecting Microsoft calendars may temporarily be unavailable during this time. Sign in using Email + Password in the meantime.

If you're having trouble signing in, complete a password reset here.

Thu, May 29, 2025, 11:46 PM(34 minutes earlier)