Otter Website Down
Resolved·Full outage

Otter systems have been fully restored.

Thu, Mar 20, 2025, 05:01 AM
(4 months ago)
·
Affected components
Otter Website
Updates

Resolved

Otter systems have been fully restored.

Thu, Mar 20, 2025, 05:01 AM

Monitoring

Our engineering team has identified the issue. We have resumed operations but will continue to monitor the situation

Wed, Mar 19, 2025, 07:04 PM(9 hours earlier)

Investigating


We are currently experiencing an outage with Otter services.

Our team is aware and working on a solution as soon as possible.

Wed, Mar 19, 2025, 06:43 PM(20 minutes earlier)