Otter Website Down
Resolved·Full outage

Otter systems have been fully restored, and conversation processing shows no delays.

Wed, Mar 19, 2025, 12:00 AM
(4 months ago)
·
Affected components
Otter Website
Speech Processing
Updates

Resolved

Otter systems have been fully restored, and conversation processing shows no delays.

Wed, Mar 19, 2025, 12:00 AM

Monitoring

While the fix has been put in place, we've found that our system is catching up on processing conversations. Conversations are still being processed but may be slightly delayed.

Tue, Mar 18, 2025, 08:28 PM(3 hours earlier)

Monitoring

We have made a fix that looks to restore all services. We're still closely monitoring the situation for any regressions.

Tue, Mar 18, 2025, 07:38 PM(50 minutes earlier)

Identified

Our team has identified the issue and is working to fully restore services.

Users should now be able to log in and use Otter but may experience some slowness.

Tue, Mar 18, 2025, 06:15 PM(1 hour earlier)

Investigating

We are currently experiencing an outage with Otter services.

Our team is aware and working on a solution as soon as possible.

Tue, Mar 18, 2025, 05:33 PM(42 minutes earlier)