Otter Website Down
Resolved·Full outage

Incident has been resolved and services are back up.

Thu, Feb 27, 2025, 02:08 AM
(2 months ago)
·
Affected components
Otter Website
Updates

Resolved

Incident has been resolved and services are back up.

Thu, Feb 27, 2025, 02:08 AM

Monitoring

Our team has quickly implemented a fix and are monitoring the situation closely.

Thu, Feb 27, 2025, 01:53 AM(14 minutes earlier)

Investigating

We are currently experience an outage with Otter services.

Our team is aware and working on a solution as soon as possible.

Thu, Feb 27, 2025, 01:34 AM(18 minutes earlier)