Website Outages
Resolved·Full outage

All issues now resolved and system should be stable.

Tue, Jan 28, 2025, 10:05 PM
(6 months ago)
·
Affected components
Otter Website
Updates

Resolved

All issues now resolved and system should be stable.

Tue, Jan 28, 2025, 10:05 PM

Monitoring

We've applied a fix and services are currently restored. We are still monitoring the situation closely to ensure quality and in case of any other issues.

Tue, Jan 28, 2025, 08:16 PM(1 hour earlier)

Identified

We've identified the issue and are looking to apply a fix as soon as possible to restore services.

We apologize for the inconvenience and appreciate your understanding.

Tue, Jan 28, 2025, 08:05 PM(10 minutes earlier)

Investigating

We're currently experiencing some sporadic outages with our website. We're currently investigating the issue to implement a fix as soon as possible.

We apologize for the inconvenience.

Tue, Jan 28, 2025, 07:18 PM(47 minutes earlier)