Resolved
Fixes have been pushed to address the issues.
Monitoring
We're monitoring some site stability issues that are occurring at our busiest times today
Monitoring
Otter Website is currently experiencing slow loading times.
Monitoring
Otter Website is back up
Investigating
We're aware of an issue with Otter currently being down. We are investigating the issue and looking to get back up and running as soon as possible.