Otter Website currently down
Monitoring
Degraded performance
Ongoing for 13h

Otter services should now be available again. We're still monitoring the situation closely.

Wed, Nov 20, 2024, 05:33 PM
13h ago
Affected components
Otter Website
Updates

Further updates will appear here

Monitoring

Otter services should now be available again. We're still monitoring the situation closely.

Wed, Nov 20, 2024, 05:33 PM
12m earlier...

Investigating

We're aware of an issue with Otter currently being down. We are investigating the issue and looking to get back up and running as soon as possible.

Wed, Nov 20, 2024, 05:21 PM