Investigating issues with new version of Chrome
Resolved

We're aware of an issue with the Otter Chrome Extension not functioning. We've found this is due to an update on Chrome's end. Unfortunately, it looks like this fix will take some time. Currently, we do not have a timeline for when this will be fixed completely. Please refer this article workarounds and updates.

Mon, Oct 21, 2024, 09:50 PM
(6 months ago)
·
Affected components

No components marked as affected

Updates

Resolved

We're aware of an issue with the Otter Chrome Extension not functioning. We've found this is due to an update on Chrome's end. Unfortunately, it looks like this fix will take some time. Currently, we do not have a timeline for when this will be fixed completely. Please refer this article workarounds and updates.

Mon, Oct 21, 2024, 09:50 PM

Investigating

We're investigating a partial outage with the Chrome Extension due to updates to the underlying Chrome browser.

As a workaround, please use OtterPilot to record any Google Meet meeting or start a manual recording in the browser.

Mon, Oct 7, 2024, 08:25 PM(2 weeks earlier)