Resolved
Otter systems have been fully restored.
Monitoring
Our engineering team has identified the issue.
We have resumed operations but will continue to monitor the situation.
Investigating
We are currently experiencing an outage affecting Notetaker's ability to join Google Meet meetings.
Our team is aware of the issue and is working on a solution as soon as possible.