Resolved
Otter systems have been fully restored.
Investigating
We are currently experiencing an issue with calendar updates not being recognized/delayed in Otter.
Any modifications to calendar; including meeting creation, deletion or changing the start time, will be delayed.
You may also see delays or Otter joining at incorrect times if the above occurred.