Resolved
Otter systems have been fully restored.
Monitoring
Our engineering team has identified the issue that may be causing speech processing delays.
Speeches will be processed, but may take longer than usual. We appreciate your patience as we work through processing speeches.