No components marked as affected
Resolved
Otter systems have been fully restored.
Monitoring
Otter experienced a brief outage, but the site should be loading again as intended. Our engineers have identified the issue.
We have resumed operations but will continue to monitor the situation.