Resolved
Otter systems have been fully restored.
Identified
Our team has identified the issue has deployed a fix to reduce the delays in speaker tagging for recorded speeches.
Investigating
We are currently experiencing an outage with Otter services.
Our team is aware and working on a solution as soon as possible.
Investigating
We are currently experiencing delays in speaker tagging.
Our team is aware and working on a solution as soon as possible.