Resolved
Otter systems have been fully restored.
Identified
Our team has identified the issue and is working to fully restore our outbound emails once more.
We've found this is due to an upstream issue and are working with our service providers to resolve the issue as soon as possible.
--------------
This may cause delays in emails going out from the Otter System which includes, but not limited to:
-Email invitations (Users will still be able to receive and accept them in app)
-Bulk Export Links
-Meeting processing and share notifications
Investigating
We are currently experiencing an issue with our outbound emails.
This may cause delays in emails going out from the Otter System which includes, but not limited to:
-Email invitations (Users will still be able to receive and accept them in app)
-Bulk Export Links
-Meeting processing and share notifications
Our team is aware and working on a solution as soon as possible.