Sitewide Outage
Resolved·Full outage

Otter systems have been fully restored.

Wed, Jan 21, 2026, 09:22 PM
(3 weeks ago)
·
Affected components
Otter Website
Updates

Resolved

Otter systems have been fully restored.

Wed, Jan 21, 2026, 09:22 PM

Monitoring

Our engineering team has identified the issue.

We have resumed operations but will continue to monitor the situation.

Wed, Jan 21, 2026, 08:23 PM(59 minutes earlier)

Investigating

We are currently experiencing an outage with Otter services.

Our team is aware and working on a solution as soon as possible.

Wed, Jan 21, 2026, 08:00 PM(23 minutes earlier)