Sitewide Outage
Resolved·Full outage

Otter systems have been fully restored.

Wed, Jan 21, 2026, 07:00 PM
(3 weeks ago)
·
Affected components
Otter Website
Updates

Resolved

Otter systems have been fully restored.

Wed, Jan 21, 2026, 07:00 PM

Monitoring

Our engineering team has identified the issue.

We have resumed operations but will continue to monitor the situation.

Wed, Jan 21, 2026, 05:16 PM(1 hour earlier)

Identified

Our team has identified the issue and is working to fully restore services.

Users should now be able to log in and use Otter but may experience some slowness.

Wed, Jan 21, 2026, 05:04 PM(11 minutes earlier)

Monitoring

Our engineering team has identified the issue.

We have resumed operations but will continue to monitor the situation.

Wed, Jan 21, 2026, 04:30 PM(34 minutes earlier)

Monitoring

Our engineering team has identified the issue.

We have resumed operations but will continue to monitor the situation.

Wed, Jan 21, 2026, 04:13 PM(17 minutes earlier)

Investigating

We are currently experiencing an outage with Otter services.

Our team is aware and working on a solution as soon as possible.

Wed, Jan 21, 2026, 04:01 PM(12 minutes earlier)